Wine und Asassins Creed

Alles rund um WINE, Cedega & CrossOver Games

Moderator: Moderator

Wine und Asassins Creed

Beitragvon ceddy » 16.04.2012, 05:57

Ich habe gestern versucht Assasins Creed mit Wine zu installieren. diese lief auch durch, jedoch will das Spiel beim ersten Start Treiber installieren und fordert dafür Admin rechte. Und wenn man nun zu stimmt die Treiber zu installieren bekommt man die Meldung, dass unzureichend rechte vorhanden sind.

Weis einer eine Lösung für dies Problem?

Ceddy
ceddy
 
Beiträge: 12
Registriert: 16.04.2012, 05:52
Lizenz: CC BY-SA 3.0

Re: Wine und Asassins Creed

Beitragvon ChemicalBrother » 16.04.2012, 09:40

Erstmal brauchen wir Antworten. Und ganz abgesehen davon: Treiber in Wine installieren solltest du schon mal gar nicht machen.

Also:
Welche Version von Assasin's Creed willst du denn in Wine spielen?
Welche Linux-Distribution hast du?
Welche Version davon?
Welche Grafikkarte hast du?
Welchen Grafiktreiber hast du installiert?
Funktioniert der?

Wenn du diese Fragen beantwortet hast, können wir anfangen, eine Lösung zu finden.
Benutzeravatar
ChemicalBrother
 
Beiträge: 5124
Registriert: 21.08.2006, 20:17
Wohnort: Langen
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 4.20

Re: Wine und Asassins Creed

Beitragvon ceddy » 16.04.2012, 09:49

Das erste Asassins Creed von gamesload geladen
Ich habe Linux Mint 12 mit Wine 1.5/1.3 beides versucht.
Eine GT 540 m mit dem X.Org-X-Server treiber

Aber das Problem sollte ja nicht im Grafik Treiber liegen denke ich:)
ceddy
 
Beiträge: 12
Registriert: 16.04.2012, 05:52
Lizenz: CC BY-SA 3.0

Re: Wine und Asassins Creed

Beitragvon ChemicalBrother » 16.04.2012, 11:33

ceddy hat geschrieben:Eine GT 540 m mit dem X.Org-X-Server treiber

Aber das Problem sollte ja nicht im Grafik Treiber liegen denke ich:)


Woher willst du wissen, dass es nicht am Grafiktreiber liegt? Mal abgesehen davon weiß ich nicht, was du mit "X.Org-X-Server treiber" meinst. Ist das jetzt der Nvidia-Treiber oder der nouveau-Treiber? In welcher Version? Richtig installiert?
Benutzeravatar
ChemicalBrother
 
Beiträge: 5124
Registriert: 21.08.2006, 20:17
Wohnort: Langen
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 4.20

Re: Wine und Asassins Creed

Beitragvon ceddy » 16.04.2012, 11:40

Weil das Programm ja windows admin rechte verlangt.
Wie gucke ich denn genau nach welchen Treiber ich habe??
ceddy
 
Beiträge: 12
Registriert: 16.04.2012, 05:52
Lizenz: CC BY-SA 3.0

Re: Wine und Asassins Creed

Beitragvon ChemicalBrother » 16.04.2012, 18:46

Mach mal

Code: Alles auswählen
glxinfo | grep -i opengl


und wenn du schon dabei bist

Code: Alles auswählen
glxinfo | grep rendering


und schreib mal die Ausgaben hier rein. Da wäre schon mal ein Anfang.
Benutzeravatar
ChemicalBrother
 
Beiträge: 5124
Registriert: 21.08.2006, 20:17
Wohnort: Langen
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 4.20

Re: Wine und Asassins Creed

Beitragvon ceddy » 16.04.2012, 18:58

Das bekomme ich als ausgabe:

cedric@cedric-Aspire-5750G ~ $ glxinfo | grep -i opengl
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
OpenGL version string: 2.1 Mesa 7.11
OpenGL shading language version string: 1.20
OpenGL extensions:


und:

glxinfo | grep rendering
direct rendering: Yes
cedric@cedric-Aspire-5750G

lg
ceddy
 
Beiträge: 12
Registriert: 16.04.2012, 05:52
Lizenz: CC BY-SA 3.0

Re: Wine und Asassins Creed

Beitragvon ChemicalBrother » 16.04.2012, 20:08

Du sagtest, du hast ne Nvidia Grafikkarte, da steht aber Intel als Grafikkarte. Ich bin gerade etwas verwirrt. Ist das dieses Nvidia Optimus Zeug? Wenn ja, dann kapituliere ich jetzt schon.
Benutzeravatar
ChemicalBrother
 
Beiträge: 5124
Registriert: 21.08.2006, 20:17
Wohnort: Langen
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 4.20

Re: Wine und Asassins Creed

Beitragvon ceddy » 16.04.2012, 20:10

Hm also eigentlich ist ne ganz normale Mobile Geforce^^ :/
ceddy
 
Beiträge: 12
Registriert: 16.04.2012, 05:52
Lizenz: CC BY-SA 3.0

Re: Wine und Asassins Creed

Beitragvon ChemicalBrother » 16.04.2012, 21:32

Deine Geforce ist da aber in Linux nicht installiert und die Intelgrafikkarte reicht definitiv nicht. Und um auf deine Eingangsvermutung einzugehen: Es liegt definitiv am Grafikkartentreiber.
Benutzeravatar
ChemicalBrother
 
Beiträge: 5124
Registriert: 21.08.2006, 20:17
Wohnort: Langen
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 4.20

Re: Wine und Asassins Creed

Beitragvon kiki_with_ubuntu2012 » 19.04.2012, 21:16

Hey,

hast du bei der Installation von LinuxMint den Haken dafür gesetzt, dass deine Distribution Drittanbietersoftware installieren darf? Meines Wissens gibt es nämlich einen entsprechenden Treiber, der jedoch nicht funktioniert, wenn das nicht entsprechend freigegeben ist!

Ansonsten versuch mal die Anwendung "PlayitonLinux", da gibt es die Installationen bereits fertig geskriptet, sodass du selbst nichts mehr konfigurieren musst. Bei mir haben darüber alle Spiele immer wunderbar funktioniert!


Liebe Grüße
kiki :)
kiki_with_ubuntu2012
 
Beiträge: 3
Registriert: 19.04.2012, 21:11
Lizenz: CC BY-SA 3.0
Distribution: Ubuntu

Re: Wine und Asassins Creed

Beitragvon Gunman1982 » 19.04.2012, 23:33

Der Laptop setzt wohl Optimus ein.
Option a: Schau im Bios ob du dauerhaft auf die nvidia Karte umstellen kannst (pro: einfach, contra: geht natürlich zu lasten von Batterie/Laufzeit)
Option b: Nutze bumblebee: http://www.bumblebee-project.org/ (pro: nvidia karte is nur an wenn ein programm die zusätzliche leistung braucht, contra: erfordert mehr arbeit)
Gunman1982
 
Beiträge: 13
Registriert: 19.04.2012, 22:39
Lizenz: CC BY-SA 3.0
Distribution: Debian GNU/Linux
Kernelversion: 3.3.0

Re: Wine und Asassins Creed

Beitragvon ceddy » 21.04.2012, 13:30

Danke ich habe mal bumblebee installiert. Wenn ich jetzt optirun glxinfo | grep -i opengl ausführe, wird mir auch die nvidia karte angezeigt. Das Problem bei Assasins cree bleibt aber trotzdem, ich habe ma nen paar screenshots gemacht:

Bild
Bild
Bild
ceddy
 
Beiträge: 12
Registriert: 16.04.2012, 05:52
Lizenz: CC BY-SA 3.0

Re: Wine und Asassins Creed

Beitragvon Gunman1982 » 22.04.2012, 21:02

Du startest wine auch mit optirun oder?
Starte mal über console, die verrät meist ein wenig mehr als solche klicki bunti Meldungen.
Gunman1982
 
Beiträge: 13
Registriert: 19.04.2012, 22:39
Lizenz: CC BY-SA 3.0
Distribution: Debian GNU/Linux
Kernelversion: 3.3.0

Re: Wine und Asassins Creed

Beitragvon ceddy » 23.04.2012, 09:05

ja, hier ist die Ausgabe:

Code: Alles auswählen
cedric@cedric-Aspire-5750G ~/.wine/drive_c/Programme/Ubisoft/Assassin's Creed $ optirun wine '/home/cedric/.wine/drive_c/Programme/Ubisoft/Assassin'\''s Creed/AssassinsCreed_Dx9.exe'
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
fixme:advapi:GetCurrentHwProfileA (0x33fba8) semi-stub
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:win:RegisterDeviceNotificationA (hwnd=0x138700, filter=0xf7e9b4,flags=0x00000001) returns a fake device notification handle!
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:advapi:RegisterEventSourceW ((null),L"Bonjour Service"): stub
fixme:advapi:ReportEventA (0xcafe4242,0x0004,0x0000,0x00000064,(nil),0x0001,0x00000000,0x79e5bc,(nil)): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0004,0x0000,0x00000064,(nil),0x0001,0x00000000,0x128b28,(nil)): stub
fixme:winsock:WSAIoctl WS_SIO_UDP_CONNRESET stub
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
fixme:winsock:WSAIoctl -> SIO_ADDRESS_LIST_CHANGE request: stub
fixme:iphlpapi:DeleteIpForwardEntry (pRoute 0x79e950): stub
fixme:iphlpapi:CreateIpForwardEntry (pRoute 0x79e988): stub
fixme:advapi:ReportEventA (0xcafe4242,0x0004,0x0000,0x00000064,(nil),0x0001,0x00000000,0x79e5bc,(nil)): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0004,0x0000,0x00000064,(nil),0x0001,0x00000000,0x128b28,(nil)): stub
fixme:service:EnumServicesStatusW resume handle not supported
fixme:service:EnumServicesStatusW resume handle not supported
fixme:advapi:ReportEventA (0xcafe4242,0x0004,0x0000,0x00000064,(nil),0x0001,0x00000000,0x79e5bc,(nil)): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0004,0x0000,0x00000064,(nil),0x0001,0x00000000,0x128b28,(nil)): stub
fixme:netapi32:NetGetJoinInformation Semi-stub (null) 0x79e674 0x79e66c
fixme:winsock:WSAIoctl WS_SIO_UDP_CONNRESET stub
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
fixme:ntoskrnl:KeInitializeTimerEx stub: 0x111080 0
fixme:ntoskrnl:IoAllocateMdl stub: 0x1112a0, 5, 0, 0, (nil)
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
fixme:ntoskrnl:IoAllocateMdl stub: 0x1112a0, 5, 0, 0, (nil)
fixme:ntoskrnl:IoAllocateMdl stub: 0x1112a0, 5, 0, 0, (nil)
fixme:ntoskrnl:IoAllocateMdl stub: 0x112700, 5, 0, 0, (nil)
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
err:service:service_send_command service protocol error - failed to read pipe r = 0  count = 0!
fixme:ntoskrnl:KeInitializeTimerEx stub: 0x111078 0
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
fixme:ntoskrnl:IoAllocateMdl stub: 0x1112b0, 5, 0, 0, (nil)
fixme:ntoskrnl:IoAllocateMdl stub: 0x1112b0, 5, 0, 0, (nil)


Modedit by ChemBro: Code besser dargestellt.
ceddy
 
Beiträge: 12
Registriert: 16.04.2012, 05:52
Lizenz: CC BY-SA 3.0

Nächste

Zurück zu Spiele unter WINE, Cedega & CrossOver Games

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

cron