Problem mit Wine/ATI

Alles rund um WINE, Cedega & CrossOver Games

Moderator: Moderator

Problem mit Wine/ATI

Beitragvon Scraey » 16.01.2012, 11:09

Hallo,

ich habe seit neusten Ubuntu auf dem PC und wollte Wine nutzen um Spiele zu starten.
Mein Problem ist, das ich nur Laggs habe und es steht Nahezu alles.

World of Warcraft - 60 FPS (niedrigste Einstellung @ 1920x1200px) kaum bewege ich mich bricht alles auf unter 20 FPS.

Counter-Strike Source hab ich DirectX 8 Errors, (google hat zu keinem Brauchbaren Ergebnis geführt)

Modern Warfare 3 startet zwar aber sobald ich ein neues Spiel erstelle hört es schon am Ladebalken auf.

Sim City 3000 Deutschland, stockt vor sich hin. Schon das Starten einer Karte dauert gut 10 Minuten.

Ich habe mich der Google suche angewendet aber nichts gefunden.
Mehrere Treiber Installationsguides durchgelesen und nachprobiert nichts hat geholfen.

Was soll ich tun? Damit ich es zum laufen bekomme?

Mein System:

AMD PhenomII X4 920+ @ 2800mhz
4GB DDRII Ram Kit 800mhz (2x 2048mb)
MSI DKA790GX Platinum Board
Gigabyte Radeon HD6870-OC

Ubuntu Oneiric Ocelot (11.10)
ATI Treiber v11.12
Scraey
 
Beiträge: 4
Registriert: 16.01.2012, 10:56
Lizenz: CC BY-SA 3.0
Distribution: Ubuntu Oneiric Ocelot
Kernelversion: 3.0.0-14

Re: Problem mit Wine/ATI

Beitragvon beko » 16.01.2012, 14:31

So viele Guides können es nicht gewesen sein. Du hast nicht eine relevante Information geliefert noch beschrieben was du wirklich probiert hast :(

Läuft 3D *wirklich*? glxinfo | grep rendering

Hast du Wine __konfiguriert___? Dazu zählt das konfigurieren des tatsächlichen RAM in der Wine Konfiguration (Google Wine Useful Registry Keys) sowie das Einstellen des Renderers auf OpenGL.

Hast du zusätzliche benötigt Pakete __für Wine__ installiert, wie z.b. DirectX (und damit ist __nicht__ die Option "Installiere DirectX" beim Installer des Spieles gemeint. Google Stichwort "winetricks").

Und dann letztendlich das Starten des Spieles über Wine __auf der Konsole__, denn nur so gibt es Debug-Ausgaben, die du hier posten kannst.

Geh das der Reihe nach durch. Nur mit "Mimimi" kann dir keiner helfen.
Benutzeravatar
beko
 
Beiträge: 596
Registriert: 25.01.2008, 21:07
Wohnort: Stuttgart
Lizenz: GPL

Re: Problem mit Wine/ATI

Beitragvon ReCon » 16.01.2012, 15:04

Zudem, welcher Treiber? Hast du dir den fglrx (offizieller AMD/ATI) Treiber installiert?
Benutzeravatar
ReCon
 
Beiträge: 1273
Registriert: 23.06.2006, 22:02
Lizenz: GPL
Distribution: openSUSE 13.1
Kernelversion: 3.11.6-4-desktop

Re: Problem mit Wine/ATI

Beitragvon Scraey » 16.01.2012, 15:27

Also Guides waren es genug das ich die schnauze voll hab...
Des kein Mimimi Thread sondern eine Frage was ich falsch mache oder besser machen kann.
Man kann nicht alles wissen wenn man das letzte mal was mit Linux zu tun hatte wo es hieß ATI und Linux zocken...niemals!^^ Also schon ein paar Jahre her!

So nun zum wesentlichen:
glxinfo | grep rendering = on
Kommt jetzt irgendwie welchen Ram du meinst ^^ Also von der Grafikkarte ist eingestellt den Ram selbst weis ich nicht wie bzw wo :/
Renderer ist auf OpenGL ^^ logisch
DirectX9 und 10 ist installiert.
und starte Counter-Strike Source über
Code: Alles auswählen
cd ~/.wine/drive_c/Programme/Steam && WINEDEBUG=-all wine steam -applaunch 240



Aktuell sehe ich bei CSS Schwarz! ^^ irgendwie fehlen da Texturen glaub ich :p


// Edit
Treiber nach dem Guide aus der Wiki
Scraey
 
Beiträge: 4
Registriert: 16.01.2012, 10:56
Lizenz: CC BY-SA 3.0
Distribution: Ubuntu Oneiric Ocelot
Kernelversion: 3.0.0-14

Re: Problem mit Wine/ATI

Beitragvon ReCon » 16.01.2012, 15:52

Zu deinem "World of Warcraft" Problem, hast du es bereits mit dem Parameter -opengl versucht?

Genau das ist das, was Beko meinte, hier fehlt wieder etwas Info um das gesamte Problem besser nachzuvollziehen: Wie hast du DirectX installiert? Mit Hilfe von winetricks?

EDIT: Mir "echtem RAM" meint Beko die Menge an RAM, welche deine Grafikkarte besitzt. Hier sollst du also einen extra Eintrag in der WINE Registry mit dem Inhalt "VideoMemorySize" anlegen. Danach solltest du mal im WINE Wiki oder eben Google schauen.
Benutzeravatar
ReCon
 
Beiträge: 1273
Registriert: 23.06.2006, 22:02
Lizenz: GPL
Distribution: openSUSE 13.1
Kernelversion: 3.11.6-4-desktop

Re: Problem mit Wine/ATI

Beitragvon Scraey » 16.01.2012, 16:06

Jap hatte ich, hab aber gerade nicht drauf um es nochmal nachzuvollziehen da ich gerade erstmal Baustelle CSS und SimCity 3k beheben will.
Installier es aber gerade wieder

Wie gesagt wenn ich das Problem eingrenzen könnte, könnte ich auch direkt danach suchen.
Da ich nicht genau weis was ihr alles braucht kann ich schlecht die Informationen liefern :-/

DirectX hab ich über winetricks installiert.

// EDIT
ReCon hat geschrieben:EDIT: Mir "echtem RAM" meint Beko die Menge an RAM, welche deine Grafikkarte besitzt. Hier sollst du also einen extra Eintrag in der WINE Registry mit dem Inhalt "VideoMemorySize" anlegen. Danach solltest du mal im WINE Wiki oder eben Google schauen.


Achso ja das hatte ich bzw ich konnte es ja über Winetricks machen, zumindestens steht es da in der config da kann ich es auf 1024 stellen

// EDIT 2

Das steht da wenn ich Counter-Strike Source starte

Code: Alles auswählen
x@x:~/.wine/drive_c/Programme/Steam$ cd ~/.wine/drive_c/Programme/Steam && WINEDEBUG=-all wine steam -applaunch 240
Using breakpad crash handler
Setting breakpad minidump AppID = 240
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198002228291 [API loaded yes]
Steam_SetMinidumpSteamID:  Setting Steam ID:  76561198002228291
warning: Unknown nb_ctl request:  4
warning: Unknown nb_ctl request:  4
warning: Unknown nb_ctl request:  4
warning: Unknown nb_ctl request:  4
warning: Unknown nb_ctl request:  4
warning: Unknown nb_ctl request:  4
Unable to remove c:\programme\steam\steamapps\gispecialone\counter-strike source\cstrike\textwindow_temp.html!
Unable to remove c:\programme\steam\steamapps\gispecialone\counter-strike source\cstrike\textwindow_temp.html!
Failed to load Steam Service
ServiceStart: failed to start
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198002228291 [API loaded yes]
Steam_SetMinidumpSteamID:  Setting Steam ID:  76561198002228291
warning: Unknown nb_ctl request:  4
warning: Unknown nb_ctl request:  4
warning: Unknown nb_ctl request:  4
warning: Unknown nb_ctl request:  4
warning: Unknown nb_ctl request:  4
warning: Unknown nb_ctl request:  4
WARNING! CThread::Terminate: SocketThread

Ich weis nur das das Menü schwarz ist und inGame seh ich auch nur Schwarz und mein HUD in Gelb

// Edit 3 CSS Problem mehr oder weniger behoben!

Ich habe an meinen Startbefehl ein -dxlevel 81 angehängt. Kann es sein das mir irgendwas in Sachen directX 9 fehlt?
Weil wenn ich es über -dxlevel 90 starte kommt ein directx 8 buffer Problem?
Scraey
 
Beiträge: 4
Registriert: 16.01.2012, 10:56
Lizenz: CC BY-SA 3.0
Distribution: Ubuntu Oneiric Ocelot
Kernelversion: 3.0.0-14

Re: Problem mit Wine/ATI

Beitragvon ChemicalBrother » 16.01.2012, 17:23

Scraey hat geschrieben:DirectX9 und 10 ist installiert.


Kann dazu führen, dass Spiele in Wine nicht mehr funktionieren. Nur so nebenbei.
Benutzeravatar
ChemicalBrother
 
Beiträge: 5153
Registriert: 21.08.2006, 21:17
Wohnort: Langen
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 5.1

Re: Problem mit Wine/ATI

Beitragvon Scraey » 16.01.2012, 18:19

Chemical_Brother hat geschrieben:
Scraey hat geschrieben:DirectX9 und 10 ist installiert.


Kann dazu führen, dass Spiele in Wine nicht mehr funktionieren. Nur so nebenbei.


Okay? Geändert, aber Problem nicht behoben *fg*
Nur noch DirectX9 drauf
Scraey
 
Beiträge: 4
Registriert: 16.01.2012, 10:56
Lizenz: CC BY-SA 3.0
Distribution: Ubuntu Oneiric Ocelot
Kernelversion: 3.0.0-14

Re: Problem mit Wine/ATI

Beitragvon LinuxDonald » 16.01.2012, 19:47

Hast auch nen saueren neuen Wine Prefix genommen? oder DX10 nur deinstalliert?

Zu dem laufen Native Games ordentlich?
Arch Linux bietet alles was das Linux Herz begehrt :)

Bild
Benutzeravatar
LinuxDonald
 
Beiträge: 831
Registriert: 23.03.2008, 16:34
Wohnort: Tangermünde
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 4.10.8

Re: Problem mit Wine/ATI

Beitragvon Bauer87 » 17.01.2012, 00:08

Scraey hat geschrieben:DirectX9 und 10 ist installiert.

Sollte man beides nicht machen. Das in Wine eingebaute DX läuft am besten unter Wine.
Benutzeravatar
Bauer87
 
Beiträge: 1233
Registriert: 31.10.2006, 23:28
Wohnort: Oldenburg
Lizenz: CC BY-SA 3.0
Distribution: Debian Stretch
Kernelversion: 4.9

Re: Problem mit Wine/ATI

Beitragvon beko » 18.01.2012, 13:20

> DirectX9 und 10 ist installiert.

Äh.. wegwerfen und neu machen. Am besten für jedes Spiel eine eigene "Winebottle" erstellen. Wie das geht habe ich hier auch schon mehrfach beschrieben. Stichwort "WINEPREFIX" (ja, groß geschrieben).

Wine kann (noch) kein DX10. Mit fast jeder Installation eines DX zerschießt du deine Wine-Umgebung ~/.wine. Das Entfernen klappt genau so gut wie ein Symantec Produkt wieder los werden. Zum Glück musst du in dem Fall nicht dein ganzes System neu aufsetzen sondern nur die aktuelle WineBottle killen (und genau darum macht man das).

Und natürlich ist es Mimimi mit "Ich habe aaalles versucht aber nur bei mir klappt es nicht weil.. äh.. ich alles versucht habe". Nicht aufgeben! Wine ist kompliziert, die Lernkurve steil doch es lohnt sich.
Benutzeravatar
beko
 
Beiträge: 596
Registriert: 25.01.2008, 21:07
Wohnort: Stuttgart
Lizenz: GPL


Zurück zu Spiele unter WINE, Cedega & CrossOver Games

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron