Anno 1701 v1.02 - Schwarzer Bildschirm [/UBUNTU]

Alles rund um WINE, Cedega & CrossOver Games

Moderator: Moderator

Anno 1701 v1.02 - Schwarzer Bildschirm [/UBUNTU]

Beitragvon freaky-m0 » 24.02.2008, 20:20

Ich habe Anno 1701 nach [url=http://wiki.linuxgaming.de/index.php/Anno_1701]DIESER[/url] Anleitung im Wiki installiert.
Patch & C*ack sind installiert. Beim starten von Anno 1701 mit wine (v0.9.55) bekomme ich lediglich einen schwarzen Bildschirm!
Ich habe schon versucht auf einem Desktop ohne Compositing (also ohne Compiz Fusion & Co) das Spiel zu starten was mich aber zum gleichen Ergebnis bringt.

Hat jemand schon Erfahrung mit Anno 1701 gesammelt oder Tipps für mich?

EDIT:

Das sind die letzten Zeilen vor dem schwarzen Bildschirm:
Code: Alles auswählen
Module  Address                Debug info     Name (0 modules)
Threads:
process  tid     prio (all id:s are in hex)
00000008
       00000009   0
0000000a
       0000000b   0
0000000c
       0000000f   0
       0000000e   0
       0000000d   0
00000010 (D) c:\windows\system32\winedevice.exe
       00000013   0 <==
       00000012   0
       00000011   0
Backtrace:
=>1 0x7b840bde (0x7ecc58a8)
  2 0x7edf7541 (0x7ecc58c8)
  3 0x7edf141c (0x7ecc5908)
  4 0x7ee6bdde in winedevice (+0xbdde) (0x7ecc59a8)
  5 0x7ee46eb3 (0x7ecc59f8)
  6 0x7bc672ba NtQueryIoCompletion+0xee6() in ntdll (0x7ecc5a08)
  7 0x7bc680c0 NtCurrentTeb+0xe04() in ntdll (0x7ecc5ab8)
  8 0x7bc68c1e ZwQueueApcThread() in ntdll (0x7ecc63d8)
  9 0xb7e8746b (0x7ecc64c8)
  10 0xb7e0a6de (0x00000000)
wine: Call from 0x7b840b64 to unimplemented function ntoskrnl.exe.KeInitializeQueue, aborting
fixme:ntoskrnl:KeInitializeTimerEx 0x110ad8 0
fixme:spoolsv:serv_main (0 (nil))
err:advapi:service_get_status service protocol error - failed to read pipe r = 0  count = 0!
fixme:win:EnumDisplayDevicesW ((null),0,0x33b548,0x00000000), stub!
fixme:d3d:IWineD3DImpl_CheckDeviceMultiSampleType Quality levels unsupported at present
Zuletzt geändert von freaky-m0 am 25.02.2008, 00:57, insgesamt 2-mal geändert.
Benutzeravatar
freaky-m0
 
Beiträge: 94
Registriert: 24.02.2008, 14:18

Beitragvon freaky-m0 » 24.02.2008, 22:21

Konfigurationsfehler meinerseits.

Problem gelöst! Tschuldigung... :thumbsup:
Benutzeravatar
freaky-m0
 
Beiträge: 94
Registriert: 24.02.2008, 14:18

Beitragvon ChemicalBrother » 24.02.2008, 23:19

Dann markiere bitte den Thread als gelöst und schreib noch, wie du es gelöst hast. Interessiert noch andere (u.a. mich :-) ).
Benutzeravatar
ChemicalBrother
 
Beiträge: 5156
Registriert: 21.08.2006, 21:17
Wohnort: Langen
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 5.1

Beitragvon freaky-m0 » 25.02.2008, 00:58

Im Registryeintrag „UseGLSL“ hatte ich statt „enabled“ >> "enable" eingetragen..

simpler Fehler große Wirkung ;)
Benutzeravatar
freaky-m0
 
Beiträge: 94
Registriert: 24.02.2008, 14:18

Beitragvon ReCon » 25.02.2008, 13:24

"UseGLSL" ist doch schon seit ein paar WINE Versionen nicht mehr nötig?!
Linux is like a wigwam: No windows, no gates and an apache inside!
_________________

Bild Team
Benutzeravatar
ReCon
 
Beiträge: 1273
Registriert: 23.06.2006, 22:02
Lizenz: GPL
Distribution: openSUSE 13.1
Kernelversion: 3.11.6-4-desktop

Beitragvon ChemicalBrother » 25.02.2008, 14:12

[quote=ReCon,index.php?page=Thread&postID=25742#post25742]"UseGLSL" ist doch schon seit ein paar WINE Versionen nicht mehr nötig?![/quote]

Es steht aber in deinem Wiki-Eintrag. ;-) Deswegen hat er es auch gemacht.

EDIT:

Bei mir geht es leider nicht weiter... :-(

Code: Alles auswählen
fixme:ntoskrnl:KeInitializeTimerEx 0x110ad8 0
fixme:font:WineEngAddFontResourceEx Ignoring flags 10
fixme:cursor:CURSORICON_LoadFromFile No support for .ani cursors.
.
.
.
fixme:win:EnumDisplayDevicesW ((null),0,0x34b4b8,0x00000000), stub!
fixme:d3d:IWineD3DImpl_CheckDeviceMultiSampleType Quality levels unsupported at present
fixme:d3d9:Direct3DShaderValidatorCreate9 stub
.
.
.
Segmentation fault (core dumped)


Da wo die Punkte sind, wiederholt sich die Ausgabe sehr oft. Wine-Version 0.9.55, Ati-Treiber 8.02, X1600 Pro.

Irgendwie will das Spiel bei mir nicht (C&C auch nicht).
Zuletzt geändert von ChemicalBrother am 25.02.2008, 15:20, insgesamt 1-mal geändert.
Benutzeravatar
ChemicalBrother
 
Beiträge: 5156
Registriert: 21.08.2006, 21:17
Wohnort: Langen
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 5.1

Beitragvon beko » 25.02.2008, 22:50

Segmentation fault (core dumped) <-- Das ist wohl das schlimmste was dir passieren kann. Wine ist mit einem Speicherzugriffsfehler abgestürzt. In dem Fall solltest du das ganze einmal mit "gdb" starten und den Backtrace (bt) den Wine-Developern zuschicken.

Vielleicht hast du Wine auch nicht richtig gebaut und solltest es eventuell noch einmal mit weniger "Optimierungen" neu bauen.
"Sir, we are surrounded!" - "Great - we can attack in any direction."

Current project: Mechanized Assault and eXploration Reloaded (maxr)
Benutzeravatar
beko
 
Beiträge: 596
Registriert: 25.01.2008, 21:07
Wohnort: Stuttgart
Lizenz: GPL

Beitragvon ChemicalBrother » 25.02.2008, 23:28

[quote=beko,index.php?page=Thread&postID=25753#post25753]Vielleicht hast du Wine auch nicht richtig gebaut und solltest es eventuell noch einmal mit weniger "Optimierungen" neu bauen.[/quote]

Ich habe Wine nicht gebaut, sondern bauen lassen. Wenn ich die Einstellungen etwas ändere, dann kommt dieses "Segmentation Fault, Core Dumped" nicht mehr, aber Anno läuft immer noch nicht. Ok, C&C läuft bei mir auch nicht, aber andere Wine-Spiele kann ich auch spielen, ohne das "Segmentation Fault" kommt.

Oder ich warte halt auf die nächste Version.
Benutzeravatar
ChemicalBrother
 
Beiträge: 5156
Registriert: 21.08.2006, 21:17
Wohnort: Langen
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 5.1

Beitragvon beko » 26.02.2008, 00:14

Seg fault bedeutet nicht, dass die ganze Anwendung unbrauchbar ist, sondern eben nur die Funktion, die hier bei deinem Spiel zufälligerweise aufgerufen wurde. Das sollte und darf nicht passieren. Hier liegt definitiv was bei wine im Argen und damit solltest du wirklich den Backtrace an die Programmierer schicken (und den Bugtracker checken ob das Problem bereits bekannt ist und gefixt wurde).
"Sir, we are surrounded!" - "Great - we can attack in any direction."

Current project: Mechanized Assault and eXploration Reloaded (maxr)
Benutzeravatar
beko
 
Beiträge: 596
Registriert: 25.01.2008, 21:07
Wohnort: Stuttgart
Lizenz: GPL

Beitragvon freaky-m0 » 26.02.2008, 20:39

Ohne den Eintrag in der Registry läut Anno1701 bei mir nicht! (Wine 0.9.55)

C&C läuft bei mir ohne Probleme solange ich nicht auf "High" bei den Grafikeinstellungen bleibe (1280x1024)



ich habe nen Intel Core2duo E6400 und ne NVIDIA GeForce 7900 GTO 512MB
Benutzeravatar
freaky-m0
 
Beiträge: 94
Registriert: 24.02.2008, 14:18

Beitragvon schaumormal » 05.01.2010, 13:52

Hallo alle zusammen,

vorweg, ich wollte nicht erst einen neuen thread eröffnen da ich denke es gibt schon einige ...

Also ich versuche seit gestern Anno 1701 auf meinem laptop mit ubuntu Linux ( Ubuntu 9.10 - Karmic Koala ) zu installieren.
Ich arbeite mit WINE 1.0.1 .

Ich habe mich an das Wiki gehalten. Habe auch selber schon tip fehler beseitigt. Ich habe es mit dem patch probiert und ohne den patch. habe nocd cracks von 1.00 bis 1.02 getestet. Nix ging. Es kam immer der startbildschirm " initialisiere spiel", danach wurde er grau und irgendwann hat es sich selbst geschlossen. unten stand error .

was mach ich falsch. Funktioniert es über haupt bei mir ?

als ich anno 1.00 mit dem crack für 1.00 gestartet habe hat er irgendwelche ressorcen geladen, dann kam das erste mal eine fehlermeldung.

fatal error or not enough disk space to write stack-Trace
kann mir jemand dazu was näheres sagen ? bitte :D

mfg
schaumormal
schaumormal
 
Beiträge: 1
Registriert: 05.01.2010, 13:18

Beitragvon ChemicalBrother » 05.01.2010, 16:03

Ich kann dir nur sagen, dass ich es letztens auch versucht habe und es nicht starten konnte, wenn das dich beruhigt. 8)
Benutzeravatar
ChemicalBrother
 
Beiträge: 5156
Registriert: 21.08.2006, 21:17
Wohnort: Langen
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 5.1


Zurück zu Spiele unter WINE, Cedega & CrossOver Games

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron