Nach Arch Installation: Windows Partition bootet nichtmehr

Hier kommt alles rein, was die restliche Software des Systems angeht.

Moderator: Moderator

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon Bauer87 » 24.11.2010, 22:16

Ich denke nein. Wahrscheinlich ist die einfachste Möglichkeit, in gparted das entsprechende Häkchen zu setzen. (fdisk sagt ja, dass die swap-Partition das bootflag hat.)
Benutzeravatar
Bauer87
 
Beiträge: 1232
Registriert: 31.10.2006, 22:28
Wohnort: Karlsruhe
Lizenz: CC BY-SA 3.0
Distribution: Debian Jessie
Kernelversion: 3.16

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon Matty265 » 24.11.2010, 22:42

Bauer87 hat geschrieben:Ich denke nein. Wahrscheinlich ist die einfachste Möglichkeit, in gparted das entsprechende Häkchen zu setzen. (fdisk sagt ja, dass die swap-Partition das bootflag hat.)

Ups, garnich gemerkt ^^ Wie kann ich das unter gparted ändern? Hab den Menüpunkt nich gefunden

EDIT:
Jetzt isses bei der Win Partition, ich schau morgen mal obs klappt
Benutzeravatar
Matty265
 
Beiträge: 465
Registriert: 17.01.2009, 12:54
Wohnort: Mönchengladbach
Lizenz: CC
Distribution: Arch

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon sixsixfive » 24.11.2010, 23:09

Bauer87 hat geschrieben:Ich denke nein.


laut http://www.linuxtopia.org/online_books/ ... ctive.html irgendwie schon, nachdem Matty das ausprobiert hat werden wir ja schlauer sein :D
Benutzeravatar
sixsixfive
 
Beiträge: 442
Registriert: 30.05.2010, 17:16
Lizenz: CC
Distribution: Wheezy-Sid-aptosid-#!-Mix
Kernelversion: current

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon Matty265 » 25.11.2010, 16:26

Nope, immernoch kein unterschied.
Hab ich irgendwo nen Flüchtigkeitsfehler drinne?
Code: Alles auswählen
Platte /dev/sda: 320.1 GByte, 320072933376 Byte
255 Köpfe, 63 Sektoren/Spur, 38913 Zylinder, zusammen 625142448 Sektoren
Einheiten = Sektoren von 1 × 512 = 512 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xa8a8a8a8

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *          19   375243007   187621494+   7  HPFS/NTFS
/dev/sda2       375243008   621230287   122993640   83  Linux
/dev/sda3       621230288   625137344     1953528+  82  Linux Swap / Solaris


# Config file for GRUB - The GNU GRand Unified Bootloader
# /boot/grub/menu.lst

# DEVICE NAME CONVERSIONS
#
#  Linux           Grub
# -------------------------
#  /dev/fd0        (fd0)
#  /dev/sda        (hd0)
#  /dev/sdb2       (hd1,1)
#  /dev/sda3       (hd0,2)
#

#  FRAMEBUFFER RESOLUTION SETTINGS
#     +-------------------------------------------------+
#          | 640x480    800x600    1024x768   1280x1024
#      ----+--------------------------------------------
#      256 | 0x301=769  0x303=771  0x305=773   0x307=775
#      32K | 0x310=784  0x313=787  0x316=790   0x319=793
#      64K | 0x311=785  0x314=788  0x317=791   0x31A=794
#      16M | 0x312=786  0x315=789  0x318=792   0x31B=795
#     +-------------------------------------------------+
#  for more details and different resolutions see
#  http://wiki.archlinux.org/index.php/GRUB#Framebuffer_Resolution

# general configuration:
timeout   5
default   0
color light-blue/black light-cyan/blue

# boot sections follow
# each is implicitly numbered from 0 in the order of appearance below
#
# TIP: If you want a 1024x768 framebuffer, add "vga=773" to your kernel line.
#
#-*

# (0) Arch Linux
title  Arch Linux
root   (hd0,1)
kernel /boot/vmlinuz26 root=/dev/sda2 ro
initrd /boot/kernel26.img

# (1) Arch Linux
title  Arch Linux Fallback
root   (hd0,1)
kernel /boot/vmlinuz26 root=/dev/sda2 ro
initrd /boot/kernel26-fallback.img

#(2) Windows
title Windows
root (hd0,0)
makeactive
chainloader +1
Benutzeravatar
Matty265
 
Beiträge: 465
Registriert: 17.01.2009, 12:54
Wohnort: Mönchengladbach
Lizenz: CC
Distribution: Arch

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon Bauer87 » 25.11.2010, 17:03

Ich würde ja fast dazu tendieren, Windows per Windows-CD wieder lauffähig zu machen und dann per chroot grub neu zu installieren.
Benutzeravatar
Bauer87
 
Beiträge: 1232
Registriert: 31.10.2006, 22:28
Wohnort: Karlsruhe
Lizenz: CC BY-SA 3.0
Distribution: Debian Jessie
Kernelversion: 3.16

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon Matty265 » 25.11.2010, 17:34

Bauer87 hat geschrieben:Ich würde ja fast dazu tendieren, Windows per Windows-CD wieder lauffähig zu machen und dann per chroot grub neu zu installieren.

Das klingt nach ner menge Arbeit? Also vllt nich unbedigt, aber ich hab noch nie mit chroot gearbeitet
Benutzeravatar
Matty265
 
Beiträge: 465
Registriert: 17.01.2009, 12:54
Wohnort: Mönchengladbach
Lizenz: CC
Distribution: Arch

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon SolidMob » 25.11.2010, 17:50

Jetzt, wo du die bootflag auf der Win-Partition hast, könntest du es ja auch nochmal mit "rootnoverify" statt nur "root" probieren.
SolidMob
 
Beiträge: 648
Registriert: 16.02.2007, 00:16
Lizenz: CC
Distribution: Ubuntu 16.04

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon Matty265 » 25.11.2010, 18:02

SolidMob hat geschrieben:Jetzt, wo du die bootflag auf der Win-Partition hast, könntest du es ja auch nochmal mit "rootnoverify" statt nur "root" probieren.

Nope :/
Benutzeravatar
Matty265
 
Beiträge: 465
Registriert: 17.01.2009, 12:54
Wohnort: Mönchengladbach
Lizenz: CC
Distribution: Arch

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon sixsixfive » 26.11.2010, 13:39

sixsixfive hat geschrieben:besorg dir eine linux live cd(mit grub legacy), xp cd einlegen, zur wiederherstellungskonsole welchseln und ein fixboot/fixmbr, sollte es dann wieder starten live cd einlegen arch platte mounten und grub oder besser lilo installieren


fixboot schon einmal ausprobiert?
Benutzeravatar
sixsixfive
 
Beiträge: 442
Registriert: 30.05.2010, 17:16
Lizenz: CC
Distribution: Wheezy-Sid-aptosid-#!-Mix
Kernelversion: current

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon Matty265 » 26.11.2010, 15:21

sixsixfive hat geschrieben:
sixsixfive hat geschrieben:besorg dir eine linux live cd(mit grub legacy), xp cd einlegen, zur wiederherstellungskonsole welchseln und ein fixboot/fixmbr, sollte es dann wieder starten live cd einlegen arch platte mounten und grub oder besser lilo installieren


fixboot schon einmal ausprobiert?

Ne noch nich, hatte bisher kaum Zeit.
Brauch ich einfach nur nach dem fixboot ne Arch LiveCD booten und folgenden Befehl eingeben?
Code: Alles auswählen
grub> setup (hd0)

Also in der Grub Shell? Oder muss ich da noch was mit chroot rumhantieren?

EDIT:
Ok wenn ich das richtig verstanden hab muss ich nur in der Grub Konsole die /boot Partition auswählen und dann erst das Setup laufen lassen, richtig?
Benutzeravatar
Matty265
 
Beiträge: 465
Registriert: 17.01.2009, 12:54
Wohnort: Mönchengladbach
Lizenz: CC
Distribution: Arch

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon sixsixfive » 28.11.2010, 13:42

Matty265 hat geschrieben:Brauch ich einfach nur nach dem fixboot ne Arch LiveCD booten und folgenden Befehl eingeben?


Nein, ich gehe mal davon aus dass dein Windows im Eimer ist

Nun könntest Du versuchen dein XP über fixboot/fixmbr(auf der XP-CD enthalten)zu reparieren, vielleicht wäre auch ein chkdsk sinnvoll, nach fixboot oder ähnlichem wird allerdings dein mbr mit GRUB überschrieben somit brauchst Du eine LiveCD um von dieser zustarten und erneut einen Bootloader in den mbr zu installieren
Benutzeravatar
sixsixfive
 
Beiträge: 442
Registriert: 30.05.2010, 17:16
Lizenz: CC
Distribution: Wheezy-Sid-aptosid-#!-Mix
Kernelversion: current

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon Matty265 » 28.11.2010, 15:00

sixsixfive hat geschrieben:
Matty265 hat geschrieben:Brauch ich einfach nur nach dem fixboot ne Arch LiveCD booten und folgenden Befehl eingeben?

somit brauchst Du eine LiveCD um von dieser zustarten und erneut einen Bootloader in den mbr zu installieren

Das meinte ich ja :D Also wie ich dann von der LiveCD aus Grub neuinstallier, und da dachte ich, ich müsse das mit den befehlen oben machen?
Benutzeravatar
Matty265
 
Beiträge: 465
Registriert: 17.01.2009, 12:54
Wohnort: Mönchengladbach
Lizenz: CC
Distribution: Arch

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon sixsixfive » 28.11.2010, 15:15

Matty265 hat geschrieben:
sixsixfive hat geschrieben:
Matty265 hat geschrieben:Brauch ich einfach nur nach dem fixboot ne Arch LiveCD booten und folgenden Befehl eingeben?

somit brauchst Du eine LiveCD um von dieser zustarten und erneut einen Bootloader in den mbr zu installieren

Das meinte ich ja :D Also wie ich dann von der LiveCD aus Grub neuinstallier, und da dachte ich, ich müsse das mit den befehlen oben machen?


jupp, einfach die arch platte irgendwohin mounten und dann grub-install --root-directory=<MOUNTPUNKT_DER_ARCH_PLATTE> /dev/sda

Du kannst natürlich auch deinen aktuellen MBR auslesen, abspeichern und ihn später wieder zurückkopieren

http://www.backuphowto.info/backup-mbr-linux
Benutzeravatar
sixsixfive
 
Beiträge: 442
Registriert: 30.05.2010, 17:16
Lizenz: CC
Distribution: Wheezy-Sid-aptosid-#!-Mix
Kernelversion: current

Re: Nach Arch Installation: Windows Partition bootet nichtmehr

Beitragvon Matty265 » 28.11.2010, 18:54

Sooo wär hätte das gedacht, die Windows Partition war echt hinüber oO Habs grad neuinstalliert und mache mich gleich mal ans Grub-Wiederherstellen

grüße

EDIT
Sooooooo, alles schnurrt wieder und läuft ;) Vielen lieben Dank! :)
Benutzeravatar
Matty265
 
Beiträge: 465
Registriert: 17.01.2009, 12:54
Wohnort: Mönchengladbach
Lizenz: CC
Distribution: Arch

Vorherige

Zurück zu Sonstige Software

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron