HID ausfälle

Hier kommt alles rein, was die restliche Software des Systems angeht.

Moderator: Moderator

HID ausfälle

Beitragvon DawnCrow » 14.09.2010, 20:33

Hi, seit einiger Zeit fällt bei mir einfach mal die Tastatur oder die Maus aus, ganz krass aber selten sogar beides.
Tastatur: PS/2 (ja, sagt nix xD)
Maus: USB

- Hatte jemand sowas schonmal?
- Woran kann das liegen?
- Was tun wenn es wieder soweit ist? Also ich mein, kann ich irgendiwie den PS/2 anschluss reset'n oder so?

Any ideas?
BildBild

Linux: It is now safe to turn on your computer.
Benutzeravatar
DawnCrow
 
Beiträge: 327
Registriert: 28.02.2009, 16:05
Wohnort: Unterfranken
Lizenz: LGPL
Distribution: Ubuntu 11.04 64-Bit, Mint 14
Kernelversion: 3.5

Re: HID ausfälle

Beitragvon Teyro » 14.09.2010, 20:36

Willkommen im Club!

Also meine Lösung damals war ein aktiver USB Hub! Anscheiend saugt ein Hardwareteil mehr Strom als dein Netzteil hergeben mag, auch wenns eig mehr kann... Ich hatte zum Beispiel mal alles in einem USB Port dann einer 4rer Hub und einen 8er beides eig. Aktiv aber die Netzteile waren nicht angesteckt ;)
Benutzeravatar
Teyro
 
Beiträge: 522
Registriert: 15.04.2007, 17:06

Re: HID ausfälle

Beitragvon sixsixfive » 14.09.2010, 21:48

Passiert dies nur bei deiner Distribution oder auch bei anderen Distributionen/Systemen?

Vieleicht solltest Du mal eine LiveCD einer anderen Distribution testen, so könntest Du einen Softwarefehler schon einmal ausschließen ;)
Benutzeravatar
sixsixfive
 
Beiträge: 442
Registriert: 30.05.2010, 17:16
Lizenz: CC
Distribution: Wheezy-Sid-aptosid-#!-Mix
Kernelversion: current

Re: HID ausfälle

Beitragvon Bauer87 » 15.09.2010, 07:16

Ich hatte das gleiche Problem auch schon bevor überhaupt GRUB geladen war. Ubuntu erkennt die Hardware dann meist, sobald es da ist, Windows dagegen lässt sie tot bis ich die Hardware neu einstecke. Die These, dass es an der Stromversorgung liegt, halte ich für recht naheliegend – das würde auch zur (grottenschlechten, quasi nicht vorhandenen) USB-Hotplug-Unterstützung von Windows passen.

USB unterstützt a priori nur 100 mA bei 5V (also ein halbes Watt), was für viele Geräte einfach zu wenig ist. Erst, wenn der Port das OK gibt, dürfen 2,5 Watt gezogen werden – die Freigabe dafür muss aber nie kommen. Wikipedia sagt:
…ohne Erlaubnis des Host mehr als 100 mA Strom beziehen. Das könnte im Extremfall den USB-Anschluss des Hosts beschädigen oder das Energiemanagement des Rechners durcheinanderbringen, was zu instabilem Verhalten führen kann.
Benutzeravatar
Bauer87
 
Beiträge: 1232
Registriert: 31.10.2006, 22:28
Wohnort: Karlsruhe
Lizenz: CC BY-SA 3.0
Distribution: Debian Jessie
Kernelversion: 3.16

Re: HID ausfälle

Beitragvon sixsixfive » 15.09.2010, 15:43

Bauer87 hat geschrieben:Die These, dass es an der Stromversorgung liegt, halte ich für recht naheliegend.


Käme für mich nur in Frage falls ich ein neues USB-Gerät hätte, bzw die Konfiguration verändert hätte...
Benutzeravatar
sixsixfive
 
Beiträge: 442
Registriert: 30.05.2010, 17:16
Lizenz: CC
Distribution: Wheezy-Sid-aptosid-#!-Mix
Kernelversion: current

Re: HID ausfälle

Beitragvon Bauer87 » 16.09.2010, 07:29

Ständige Überlastung lässt Spannungswandler schneller altern, sodass eventuell erst jetzt nicht mehr genügend Leistung geliefert werden kann. Was dem entgegen spricht wäre nur, dass du ja auch eine PS/2-Tastatur benutzt.
Benutzeravatar
Bauer87
 
Beiträge: 1232
Registriert: 31.10.2006, 22:28
Wohnort: Karlsruhe
Lizenz: CC BY-SA 3.0
Distribution: Debian Jessie
Kernelversion: 3.16

Re: HID ausfälle

Beitragvon sixsixfive » 16.09.2010, 16:51

Bauer87 hat geschrieben:Ständige Überlastung lässt Spannungswandler schneller altern


Was meinst Du mit ständiger Überlastung? Wenn Du nicht mehr als ein USB-Gerät pro Buchse ansteckst wird wohl nie etwas überlastet werden

Bauer87 hat geschrieben:Was dem entgegen spricht wäre nur, dass du ja auch eine PS/2-Tastatur benutzt.


ups, den PS/2 hab ich ganz übersehen, in dem Fall(wenn ich nichts neues eingebaut hätte)würde ich mal das Netzteil checken, danach wär das Mainboard dran... vielleicht hast Du irgendeinen Spannungsabfall durch ein defektes Bauteil...
Benutzeravatar
sixsixfive
 
Beiträge: 442
Registriert: 30.05.2010, 17:16
Lizenz: CC
Distribution: Wheezy-Sid-aptosid-#!-Mix
Kernelversion: current


Zurück zu Sonstige Software

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron