True Combat: Elite (kein Sound)

Hier könnt ihr Probleme, Anmerkungen, Infos, Beschreibungen,... zu nativen Linux-Games posten.

Moderator: Moderator

True Combat: Elite (kein Sound)

Beitragvon Fanta » 10.10.2006, 11:16

Sooo ich habe keinen sound unter True Combat: Elite wie kann ich das Spiel über oss oder so starten
Fanta
 
Beiträge: 95
Registriert: 20.09.2006, 21:38

Beitragvon DoubleU » 10.10.2006, 11:22

Versuchs mal mit
aoss /Pfad/zur/tc-elite


Gruß DoubleU
IRC-Server: irc.freenode.net IRC-Channel: #linuxgaming.de
TeamSpeak Server: https://www.linuxgaming.de


Bild
Benutzeravatar
DoubleU
 
Beiträge: 2031
Registriert: 28.06.2006, 12:16
Wohnort: Gemany

Beitragvon Fanta » 10.10.2006, 11:35

bash: aoss: command not found
Fanta
 
Beiträge: 95
Registriert: 20.09.2006, 21:38

Beitragvon DoubleU » 10.10.2006, 11:41

Habs gerade mit aoss versucht und da hat man zwar Ton aber nur eine Art rauschen. Wenn ich was besseres finde meld ich mich.
IRC-Server: irc.freenode.net IRC-Channel: #linuxgaming.de
TeamSpeak Server: https://www.linuxgaming.de


Bild
Benutzeravatar
DoubleU
 
Beiträge: 2031
Registriert: 28.06.2006, 12:16
Wohnort: Gemany

Beitragvon Fanta » 10.10.2006, 11:43

ok hatte es net geinstallt nu krazt alles im game
Fanta
 
Beiträge: 95
Registriert: 20.09.2006, 21:38

Beitragvon Cyberspace19 » 10.10.2006, 12:03

Kenne das mit dem kratzigen Sound von Quake4. Schau mal nach ob Du in deinem Homeverzeichnis einen versteckten Ordner findest, in dem die Konfig von dem Spielt liegt. (Bei Quake4 ist es ~/.quake4/...)

Wenn Du die Konfig hast, dann schau da mal nach ob es einen Parameter wie s_driver, sound, sound_driver,... gibt und was da eingestellt ist. Bei Quake4 musste man den nämlich von "best" auf "oss" ändern und der Sound funktionierte wunderbar.

#Greetz,
Cyberspace19
IRC-Server: irc.freenode.net IRC-Channel: #linuxgaming.de
TeamSpeak Server: https://www.linuxgaming.de
Benutzeravatar
Cyberspace19
 
Beiträge: 2693
Registriert: 22.06.2006, 15:24
Lizenz: FDL

Beitragvon Cheeky@Boinc » 10.10.2006, 14:42

Die Konfigurationsdatei von True Combat befindet sich unter "/home/USER/.etwolf/tcetest/" :)
<3 SuL <3
Benutzeravatar
Cheeky@Boinc
 
Beiträge: 7387
Registriert: 28.06.2006, 14:19
Wohnort: Werther
Lizenz: GPL

Beitragvon Fanta » 10.10.2006, 19:40

hi also ich finde nur ne et conf aber auch nur unter root da ist kein sound Parameter
Fanta
 
Beiträge: 95
Registriert: 20.09.2006, 21:38

Beitragvon Cheeky@Boinc » 10.10.2006, 19:54

Also nochmal genauer:

Code: Alles auswählen
/home/USER/.etwolf/tcetest/profiles/DEINPROFIL/etconfig.cfg


..das ist die Datei =)

Aber davon ab, starte das Spiel mal mit:

Code: Alles auswählen
+set s_initsound 0


..und poste mal die Fehlermeldung die das Spiel in der Konsole bei "Sound" hinterlässt.
Mit und ohne diesem "initsound"
<3 SuL <3
Benutzeravatar
Cheeky@Boinc
 
Beiträge: 7387
Registriert: 28.06.2006, 14:19
Wohnort: Werther
Lizenz: GPL

Beitragvon Fanta » 10.10.2006, 20:03

den genauen Fehler konnte ich net analysieren



ET 2.60 linux-i386 Mar 10 2005
----- FS_Startup -----
Current search path:
/home/fanta/.etwolf/tcetest/zzzz_plaixmodbc.pk3 (10 files)
/home/fanta/.etwolf/tcetest/pak3.pk3 (89 files)
/home/fanta/.etwolf/tcetest
/usr/local/games/enemy-territory/tcetest/pak3.pk3 (411 files)
/usr/local/games/enemy-territory/tcetest/pak2.pk3 (2066 files)
/usr/local/games/enemy-territory/tcetest/pak1.pk3 (1869 files)
/usr/local/games/enemy-territory/tcetest/pak0.pk3 (728 files)
/usr/local/games/enemy-territory/tcetest/mp_bin.pk3 (6 files)
/usr/local/games/enemy-territory/tcetest
/home/fanta/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak2.pk3 (22 files)
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (6 files)
/usr/local/games/enemy-territory/etmain

----------------------
8942 files in pk3 files
^3WARNING: profile.pid found for profile Fanta - system settings will revert t o defaults
execing default.cfg
couldnt exec language.cfg
execing profiles/Fanta/etconfig.cfg
r_smp is unsafe. Check com_crashed.
r_mode is unsafe. Check com_crashed.
r_depthbits is unsafe. Check com_crashed.
r_stencilbits is unsafe. Check com_crashed.
r_stereo is unsafe. Check com_crashed.
r_colorbits is unsafe. Check com_crashed.
r_texturebits is unsafe. Check com_crashed.
r_clampToEdge is unsafe. Check com_crashed.
r_ext_texture_env_add is unsafe. Check com_crashed.
r_nv_fogdist_mode is unsafe. Check com_crashed.
r_ext_NV_fog_dist is unsafe. Check com_crashed.
r_ext_texture_filter_anisotropic is unsafe. Check com_crashed.
r_ati_fsaa_samples is unsafe. Check com_crashed.
r_ati_truform_pointmode is unsafe. Check com_crashed.
r_ati_truform_normalmode is unsafe. Check com_crashed.
r_ati_truform_tess is unsafe. Check com_crashed.
r_ext_ATI_pntriangles is unsafe. Check com_crashed.
r_glIgnoreWicked3D is unsafe. Check com_crashed.
r_ext_compiled_vertex_array is unsafe. Check com_crashed.
r_ext_multitexture is unsafe. Check com_crashed.
r_ext_gamma_control is unsafe. Check com_crashed.
r_ext_compressed_textures is unsafe. Check com_crashed.
r_allowExtensions is unsafe. Check com_crashed.
r_glDriver is unsafe. Check com_crashed.
com_zoneMegs will be changed upon restarting.
execing autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: RADEON 9800 Pro Generic
Initializing OpenGL extensions
...using GL_S3_s3tc
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
...GL_NV_fog_distance not found
...ignoring GL_EXT_texture_filter_anisotropic
Initializing GLX extensions
... GLX_SGI_swap_control not found
... GLX_SGI_video_sync not found
XF86 Gamma extension initialized

GL_VENDOR: ATI Technologies Inc.
GL_RENDERER: RADEON 9800 Pro Generic
GL_VERSION: 2.0.5814 (8.25.18)
GL_EXTENSIONS: GL_ARB_multitexture GL_EXT_texture_env_add GL_EXT_compiled_vertex _array GL_S3_s3tc GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_fragment_p rogram_shadow GL_ARB_fragment_shader GL_ARB_multisample GL_ARB_occlusion_query G L_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects GL_ARB_shading_ language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_te xture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_tex ture_mirrored_repeat GL_ARB_transpose_matrix GL_ARB_vertex_blend GL_ARB_vertex_b uffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ARB _draw_buffers GL_ATI_draw_buffers GL_ATI_element_array GL_ATI_envmap_bumpmap GL_ ATI_fragment_shader GL_ATI_map_object_buffer GL_ATI_separate_stencil GL_ATI_text ure_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_ATI_vertex_a rray_object GL_ATI_vertex_attrib_array_object GL_ATI_vertex_streams GL_ATIX_text ure_env_combine3 GL_ATIX_texture_env_route GL_ATIX_vertex_shader_output_point_si ze GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_ blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_draw_range_ele ments GL_EXT_fog_coord GL_EXT_framebuffer_object GL_EXT_multi_draw_arrays GL_EXT _packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_co lor GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_EX T_texgen_reflection GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_text ure_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture _env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_textu re_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_arr ay GL_EXT_vertex_shader GL_HP_occlusion_test GL_NV_blend_square GL_NV_occlusion_ query GL_NV_texgen_reflection GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGI S_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_mul ti_draw_arrays
GLX_EXTENSIONS: GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_import_context GLX_ARB_get_proc_address GLX_ARB_multisample
GL_MAX_TEXTURE_SIZE: 2048
GL_MAX_ACTIVE_TEXTURES_ARB: 8

PIXELFORMAT: color(24-bits) Z(24-bit) stencil(0-bits)
MODE: 4, 800 x 600 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU:
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_LINEAR
picmip: 0
texture bits: 0
multitexture: enabled
compiled vertex arrays: enabled
texenv add: disabled
compressed textures: enabled
anisotropy: 1.0
NV distance fog: disabled
Initializing Shaders
----- finished R_Init -----

------- sound initialization -------
/dev/dsp: Device or resource busy
Could not open /dev/dsp
------------------------------------
Sound memory manager started
Sys_LoadDll(/home/fanta/.etwolf/tcetest/ui.mp.i386.so)...
Sys_LoadDll(/home/fanta/.etwolf/tcetest/ui.mp.i386.so) failed:
"/home/fanta/.etwolf/tcetest/ui.mp.i386.so: cannot open shared object file: No s uch file or directory"
Sys_LoadDll(/usr/local/games/enemy-territory/tcetest/ui.mp.i386.so)... ok
Sys_LoadDll(ui) found **vmMain** at 0x9a4b5044
Sys_LoadDll(ui) succeeded!
WARNING: reused image ui/assets/fadebox.tga with mixed glWrapClampMode parm
--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: Local
IP: 127.0.1.1
Started tty console (use +set ttycon 0 to disable)
^5PunkBuster Client: Attempting to resolve master6.evenbalance.com
^5PunkBuster Client: Resolved to [69.59.149.240]
^5PunkBuster Client: PunkBuster Client (v1.274 | A0) Enabled
^5PunkBuster Client: Game Version [ET 2.60 linux-i386 Mar 10 2005]
^5PunkBuster Client: Not Connected to a Server
^3WARNING: unknown UI script 0
^3WARNING: unknown UI script 1
Resolving etmaster.idsoftware.com
etmaster.idsoftware.com resolved to 192.246.40.60:27951
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Shutdown tty console
Fanta
 
Beiträge: 95
Registriert: 20.09.2006, 21:38

Beitragvon Cheeky@Boinc » 10.10.2006, 20:18

------- sound initialization -------
/dev/dsp: Device or resource busy
Could not open /dev/dsp
------------------------------------


Da ist das Problem :)

Hast du meinen Tipp befolgt?

Was hast du alles noch nebenbei laufen? Mal einen Mediaplayer oder TeamSpeak beenden !

Ansonsten stell mal in der Datei,

Code: Alles auswählen
/home/USER/.etwolf/tcetest/profiles/DEINPROFIL/etconfig.cfg


...

Code: Alles auswählen
seta snddevice "/dev/dsp"


..auf

Code: Alles auswählen
seta snddevice "oss"


..ob das vielleicht etwas bringt / ob das geht
<3 SuL <3
Benutzeravatar
Cheeky@Boinc
 
Beiträge: 7387
Registriert: 28.06.2006, 14:19
Wohnort: Werther
Lizenz: GPL

Beitragvon Fanta » 10.10.2006, 20:21

ne hatte ich auch schon
Fanta
 
Beiträge: 95
Registriert: 20.09.2006, 21:38

Beitragvon Fanta » 10.10.2006, 20:23

+set s_initsound 0 damit kann ich das nich starten und nix neben bei
Zuletzt geändert von Fanta am 10.10.2006, 20:25, insgesamt 1-mal geändert.
Fanta
 
Beiträge: 95
Registriert: 20.09.2006, 21:38

Beitragvon Cyberspace19 » 10.10.2006, 20:24

Würde auch darauf tippen, dass irgendwo im Hintergrund noch ein Prozess läuft, welcher das Device /dev/dsp in Beschlag hat. Hast Du wirklich nicht noch so etwas wie TeamSpeak, Skype,... am laufen oder vielleicht noch irgendwelche Klang/Soundkomponenten?

#Greetz,
Cyberspace19
IRC-Server: irc.freenode.net IRC-Channel: #linuxgaming.de
TeamSpeak Server: https://www.linuxgaming.de
Benutzeravatar
Cyberspace19
 
Beiträge: 2693
Registriert: 22.06.2006, 15:24
Lizenz: FDL

Beitragvon Fanta » 10.10.2006, 20:28

ne habe grade ALLES zu

und nix an sound in game

gibts nen befehl um zu sehen was auf /dev/dsp zugreift
Zuletzt geändert von Fanta am 10.10.2006, 20:28, insgesamt 1-mal geändert.
Fanta
 
Beiträge: 95
Registriert: 20.09.2006, 21:38

Nächste

Zurück zu Native Linux Spiele

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron