Problem mit Steam streaming und OpenGL

Hier könnt ihr Probleme, Anmerkungen, Infos, Beschreibungen,... zu nativen Linux-Games posten.

Moderator: Moderator

Re: Problem mit Steam streaming und OpenGL

Beitragvon Sepheran » 01.06.2014, 16:54

Die Karte übernimmt auch den Sound läuft das auch mit den freien treibern?
Benutzeravatar
Sepheran
 
Beiträge: 11
Registriert: 31.05.2014, 11:12
Lizenz: CC BY-SA 3.0

Re: Problem mit Steam streaming und OpenGL

Beitragvon Bauer87 » 01.06.2014, 17:34

Zumindest bei meiner HD5750 läuft das ohne Probleme. Bei einigen Kernel-Versionen musste man noch nen Startparameter angeben, mein Grub startet Linux mit „radeon.audio=1“, aber das war es dann auch.
Benutzeravatar
Bauer87
 
Beiträge: 1233
Registriert: 31.10.2006, 23:28
Wohnort: Oldenburg
Lizenz: CC BY-SA 3.0
Distribution: Debian Stretch
Kernelversion: 4.9

Re: Problem mit Steam streaming und OpenGL

Beitragvon ReCon » 01.06.2014, 21:03

Bei mir war es ähnlich, sowohl Host (Win 7 x64), sowohl Client (openSUSE 13.1 x64) sind abgestürzt.

Der Grund: Die Firewall war aktiv. Bei Windows und openSUSE deaktiviert und schon lief die Sache.
Benutzeravatar
ReCon
 
Beiträge: 1273
Registriert: 23.06.2006, 22:02
Lizenz: GPL
Distribution: openSUSE 13.1
Kernelversion: 3.11.6-4-desktop

Re: Problem mit Steam streaming und OpenGL

Beitragvon Sepheran » 02.06.2014, 12:03

So ich hab jetzt wie ChemicalBrother sagt auf Mint 17 gewechselt, hab diesmal keinen amd treiber installiert und der stream läuft :thumbup:

Allerdings war jetzt der sound so knisterig und verzerrt :S
Benutzeravatar
Sepheran
 
Beiträge: 11
Registriert: 31.05.2014, 11:12
Lizenz: CC BY-SA 3.0

Re: Problem mit Steam streaming und OpenGL

Beitragvon ChemicalBrother » 02.06.2014, 19:28

Das könnte an PulseAudio liegen und es gibt auch, glaube ich, hier irgendwo im Forum ne Abhilfe dazu, aber ich habe vergessen, was man da einstellen muss. Oder war das bei Ubuntuusers? Aber generell dürfte PulseAudio das Problem sein.
Benutzeravatar
ChemicalBrother
 
Beiträge: 5238
Registriert: 21.08.2006, 21:17
Wohnort: Langen
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 5.9

Re: Problem mit Steam streaming und OpenGL

Beitragvon beko » 03.06.2014, 21:25

Zur Info für den nächsten mit dem selben Problem:

Steam braucht zum Streamen die libvideo (32bit natürlich vermutlich).

Die ist auch bei meiner alten Mint Installation nicht installiert :(
Benutzeravatar
beko
 
Beiträge: 595
Registriert: 25.01.2008, 21:07
Lizenz: GPL

Re: Problem mit Steam streaming und OpenGL

Beitragvon Sepheran » 13.07.2014, 15:33

Hallo,

Sorry das ich jetzt so spät wieder damit komme aber hatte leider zuletzt wenig zeit um mich damit auseinander zu setzten.

Ich hab mal das PulseAudio ausgeschaltet in dem ich in der Konsole pulseaudio -k eingegeben hab, stand so im Internet, war das richtig?
Es hat eine Verbesserung bewirkt aber ok ist es leider immer noch nicht.
Benutzeravatar
Sepheran
 
Beiträge: 11
Registriert: 31.05.2014, 11:12
Lizenz: CC BY-SA 3.0

Re: Problem mit Steam streaming und OpenGL

Beitragvon Bauer87 » 14.07.2014, 22:04

Ich hab das Problem jetzt auch – und zwar unabhängig vom Streaming. Der Gag ist, dass ich definitiv direct Rendering habe. Aus Steam heraus starten die meisten Spiele dennoch aktuell nicht – wohl aber, wenn ich direkt zum Installationspfad wechsle und das Spiel direkt (und nicht von steam aus) starte. Ich habe das Gefühl, dass irgendeine von Steam mitgelieferte Binary (Steam linkt ja nicht dynamisch das, was das System anbietet) nicht mit dem Rest meines Debians zusammen passt. Die letzten Tage kamen unter anderem Updates für Mesa, als auch für Libc6 und Libgcc (Debian Testing).
Benutzeravatar
Bauer87
 
Beiträge: 1233
Registriert: 31.10.2006, 23:28
Wohnort: Oldenburg
Lizenz: CC BY-SA 3.0
Distribution: Debian Stretch
Kernelversion: 4.9

Vorherige

Zurück zu Native Linux Spiele

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron