ATI radeon 9200

Hier geht es um Hardware/Peripherie. Probleme, neue Treiber... werden hier diskutiert.

Moderator: Moderator

ATI radeon 9200

Beitragvon Mr.HuLa.BuLa » 03.01.2007, 19:49

hi
ich hab mich grad mal hier durchgelesen und diese anleitung gefunden

AMD (ATI) Treiber Installieren

ich hab alles befolgt aber im endefekt ging nichts ;(

z.B also ich das gemacht hab bei teil 1 von der anleitung
ich hab denn traiber von ati runtergeladen und auch installieren können aber dann als ich

das machen musste:
___________________________________________________________________________________
4. Jetzt muss die "xorg.conf" editiert werden...

Code: Alles auswählen
sudo kate /etc/X11/xorg.conf

In der Zeile "Driver",

Code: Alles auswählen
Section "Device"
        Identifier      "ATI Technologies, Inc. Radeon 9500 Pro (R300 AD)"
        Driver          "fglrx"
        BusID           "PCI:1:0:0"
EndSection


...muss "fglrx" stehen!

4. ..reboot..und es sollte geklappt haben smile
Testen kann man das mit einem 3D Spiel oder mit dem Befehl "fglrxinfo".
Wenn dort nicht MESA als Treiber steht war die Installation erfolgreich!

Code: Alles auswählen
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 Generic
OpenGL version string: 2.0.6234 (8.32.5)

_______________________________________________________________________________________

bei mir sah das aber so aus, als ich das eingeben hab:

Code: Alles auswählen
sudo kate /etc/X11/xorg.conf


Code: Alles auswählen
Section "Device"
   Identifier   "ATI Technologies, Inc. RV280 [Radeon 9200]"
   Driver      "fglrx"
   BusID      "PCI:1:0:0"


als ich dann reboot gemacht hab und voller hoffnung war kamm dann nach dem befehl: fglrxinfo

das hier:

Code: Alles auswählen
masterkillers@masterkillers:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)


also ist alles fehlgeschlagen obwohl ich es öfter versucht hab :(

>__________________________________________________________________

dann stand unten noch was von problemlösung

das hier:
Ab Ubuntu 6.06

....braucht man die "restricted-modules" nicht mehr entfernen sonder nutzt das eingebaute "blacklist" Feature:

Die Datei "linux-restricted-modules-common" Editieren...

Code: Alles auswählen
sudo kate /etc/default/linux-restricted-modules-common


...und dort,

Code: Alles auswählen
DISABLED_MODULES="fglrx"


....einfügen !

_______________________________________________________________________
das stand aber bei mir schon drin :) warum weiss ich auch nicht

dann kamm noch das bei der anleitung:

Alle Ubuntu bis Breezy

Solltet ihr vorher den "fglrx" Treiber aus den Paketquellen genutzt haben müsst ihr erst folgendes tun:

Code: Alles auswählen
xorg-driver-fglrx
fglrx-control
linux-restricted-modules-


da wusste ich nicht was ich damit machen sollte :( weil ich auch nicht wusste ob ich vorher fglrx hatte


was ich noch weiss das bevor ich angefangen hab bei mir in kate das so dran stand

Code: Alles auswählen
Section "Device"
   Identifier   "ATI Technologies, Inc. RV280 [Radeon 9200]"
   Driver      "ati"
   BusID      "PCI:1:0:0"


ich weiß nicht was ich falsch mach es geht einfach nichts und ich komm einfach nich vorran
_______________________________________________________________________________________

denn letzten schritt hab ich auch gemacht

Installation des Open Source Treibers:

am ende sollte dran stehen direct rendering: Yes

da stand aber drann

Code: Alles auswählen
masterkillers@masterkillers:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
    GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  1 0 None
0x24 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  1 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x27 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  1 0 None
0x28 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  1 0 None
0x29 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x2a 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None


also NO :(

kann mir jemand weiterhelfen weil ich brauch nen traiber will CSS zocken ;)

aber bitte nicht alles so schwer erklähren weil ich bin noch ein neuling ^^ und ich habe Kubuntu 6.06 ;)

MFG Mr.HuLa.BuLa
Bild
Benutzeravatar
Mr.HuLa.BuLa
 
Beiträge: 274
Registriert: 03.01.2007, 15:20
Wohnort: Augsburg

Beitragvon Mr.HuLa.BuLa » 03.01.2007, 19:59

hab jetzt grad gelesen das da AMD (ATI) Treiber Installieren steht :O

also ich hab nen intel 4: 2,4gh oder steht das AMD für etwas anderes ? :D
Bild
Benutzeravatar
Mr.HuLa.BuLa
 
Beiträge: 274
Registriert: 03.01.2007, 15:20
Wohnort: Augsburg

Beitragvon Cheeky@Boinc » 03.01.2007, 20:03

Ich möchte zwar nicht mit meckern Anfangen aber es geht nicht anders....

Bitte les dir die Anleitung doch in Ruhe durch ! Gerne auch mehrmals!

Denn:

1. Warum Installierst du neben dem ATI Treiber von der Homepage auch noch den OpenSource Treiber?
Das geht natürlich nicht zusammen.

2. Wenn bei dir "DISABLED_MODULES="fglrx"" steht ist klar warum der Treiber nicht funktioniert.
Damit wird der Treiber nämlich deaktiviert.
Das steht in den Problemlösungen drin damit man die "Restricted Modules" nicht mehr entfernen muss wenn man den Originalen Treiber nicht nutzen möchte sondern einen anderen.

3.

da wusste ich nicht was ich damit machen sollte weil ich auch nicht wusste ob ich vorher fglrx hatte


Hast du "Ubuntu Breezy" ? Nein? Warum meinst du dann das du diesen schritt voillziehen musst?

Also. Bitte ! Nicht einfach "schnell schnell" etwas machen wollen sondern mit bedacht lesen.

Du entfernst nun das ""DISABLED_MODULES="fglrx"

Code: Alles auswählen
sudo kate /etc/default/linux-restricted-modules-common


und Installierst den Treiber noch einmal nach der Anleitung :)
Danach machst du Sicherheitshalber in einer Konsole

Code: Alles auswählen
sudo depmod -a && sudo modprobe fglrx


...rebooten und vielleicht geht es ja nun.

Ich drück dir die Daumen ;)

Edit:

ATI = AMD ;) AMD hat ATI geschluckt
<3 SuL <3
Benutzeravatar
Cheeky@Boinc
 
Beiträge: 7387
Registriert: 28.06.2006, 14:19
Wohnort: Werther
Lizenz: GPL

Beitragvon Mr.HuLa.BuLa » 03.01.2007, 20:13

ok danke für deine schnelle antwort :)

hab das nicht gewusst das man nicht alles machen darf :(

werde es nochmal machen von neu :)
Bild
Benutzeravatar
Mr.HuLa.BuLa
 
Beiträge: 274
Registriert: 03.01.2007, 15:20
Wohnort: Augsburg

Beitragvon Mr.HuLa.BuLa » 03.01.2007, 20:44

es klappt nicht :(

irgentwo ist da nen hacken

könntest du mir sagen was ich am besten machen soll ?
ich hab jetzt das DISABLED_MODULES="fglrx wieder gelöscht

dann alle schritte von oben

Installation des Treibers von der ATI Homepage:

dann kommt ja die schritte zur problem lösung

da steht doch:


....braucht man die "restricted-modules" nicht mehr entfernen sonder nutzt das eingebaute "blacklist" Feature:

Die Datei "linux-restricted-modules-common" Editieren...

code:

1:sudo gedit /etc/default/linux-restricted-modules-common



...und dort,

code:

1:DISABLED_MODULES="fglrx"


....einfügen !


du hast ja gesagt das ich das rauslöschen sollte also hab ich diesen schritt jetzt ausgelassen weil sonst würde es ja genau so sein wie vorher:

Alle Ubuntu bis Breezy

Solltet ihr vorher den "fglrx" Treiber aus den Paketquellen genutzt haben müsst ihr erst folgendes tun:

code:

xorg-driver-fglrx
fglrx-control
linux-restricted-modules-


...entfernen und in der "/etc/X11/xorg.conf " das "fglrx" in "ati" ändern!
Danach neustarten und mit der installation beginnen.


diesen schritt hab ich auch ausgelassen da ich sonst kompeltt aufgeschmissen bin da steht fglrx in ati ändern aber oben in der anleiten steht ja wiederrum in fglrx ändern Oo


Solltet ihr vorher den "fglrx" Treiber aus den Paketquellen genutzt haben müsst ihr erst folgendes tun:
gehört das vieleicht zu dem TEIL 2 ?
weil da steht nemlich Installation des Treibers aus den Paketquellen:

mein kopf platzt fast ich versuch das schon seit 3uhr :(
Bild
Benutzeravatar
Mr.HuLa.BuLa
 
Beiträge: 274
Registriert: 03.01.2007, 15:20
Wohnort: Augsburg

Beitragvon Mr.HuLa.BuLa » 03.01.2007, 21:03

sry für 3fach post aber

in meiner KDE leiste ist jetzt ein ATI simbol drin (ATI Control)

da steht auch drin welche karte ich hab und so :] also es hat sich was getan


EDIT:

JA MAN BÄM ^^

Code: Alles auswählen
masterkillers@masterkillers:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9250/9200 Series DDR Generic
OpenGL version string: 1.3.1091 (X4.3.0-8.28.8)

masterkillers@masterkillers:~$


hehe also stimmt doch so ? :]

passt das soweit ?
oder muss ich noch weitere schritte befoglen ? :rolleyes:


EDIT 2:

Code: Alles auswählen
masterkillers@masterkillers:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
    GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9250/9200 Series DDR Generic
OpenGL version string: 1.3.1091 (X4.3.0-8.28.8)
OpenGL extensions:
    GL_ARB_multitexture, GL_EXT_texture_env_add, GL_EXT_compiled_vertex_array,
    GL_S3_s3tc, GL_ARB_occlusion_query, GL_ARB_point_parameters,
    GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
    GL_ARB_transpose_matrix, GL_ARB_vertex_blend, GL_ARB_vertex_buffer_object,
    GL_ARB_vertex_program, GL_ARB_window_pos, GL_ATI_element_array,
    GL_ATI_envmap_bumpmap, GL_ATI_fragment_shader, GL_ATI_map_object_buffer,
    GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,
    GL_ATI_vertex_array_object, GL_ATI_vertex_attrib_array_object,
    GL_ATI_vertex_streams, GL_ATIX_texture_env_combine3,
    GL_ATIX_texture_env_route, GL_ATIX_vertex_shader_output_point_size,
    GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
    GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_rescale_normal,
    GL_EXT_secondary_color, GL_EXT_separate_specular_color,
    GL_EXT_stencil_wrap, GL_EXT_texgen_reflection, GL_EXT_texture3D,
    GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
    GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
    GL_EXT_vertex_shader, GL_HP_occlusion_test, GL_NV_blend_square,
    GL_NV_occlusion_query, GL_NV_texgen_reflection, GL_SGI_color_matrix,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  1 0 Slow
0x24 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  1 0 Slow
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  1 0 Slow
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  1 0 Slow
0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  1 0 None
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  1 0 None
0x29 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  1 0 None
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  1 0 None
0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  1 0 Slow
0x2c 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  1 0 Slow
0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  1 0 Slow
0x2e 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  1 0 Slow
0x2f 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  1 0 None
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  1 0 None
0x31 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  1 0 None
0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  1 0 None


da steht jetzt direct rendering: Yes sau geil :)

da ich jetzt glaube das ich es richtig gemacht habe nur noch eine frage was bringt mir das jetzt genau ?
hab ich dadurch viel vorteile ?

MFG Mr.HuLa.BuLa :yes!:
Zuletzt geändert von Mr.HuLa.BuLa am 03.01.2007, 21:09, insgesamt 2-mal geändert.
Bild
Benutzeravatar
Mr.HuLa.BuLa
 
Beiträge: 274
Registriert: 03.01.2007, 15:20
Wohnort: Augsburg

Beitragvon Cheeky@Boinc » 04.01.2007, 10:14

da ich jetzt glaube das ich es richtig gemacht habe nur noch eine frage was bringt mir das jetzt genau ?


Ne wofür Installiert man wohl nen 3D Treiber :D
Klar, für 3D Beschleunigung ! Viel Spass mit CS ;)
<3 SuL <3
Benutzeravatar
Cheeky@Boinc
 
Beiträge: 7387
Registriert: 28.06.2006, 14:19
Wohnort: Werther
Lizenz: GPL


Zurück zu Hardware/Peripherie

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste