Neuer ATI/AMD-Grafiktreiber Catalyst 8.5

Neue Treiberversionen und Informationen zu neuer Hardware sind hier zu finden.

Moderator: Moderator

Neuer ATI/AMD-Grafiktreiber Catalyst 8.5

Beitragvon Cheeky@Boinc » 21.05.2008, 20:55

Bild

Neuer Treiber mit vielen Fixes und neuen Features wie Kernel 2.6.25 unterstützung, verbesserter 2D Performance, verbessertem Control Center mit neuen Funktionen und unterstüzung für die Karten RV770, M98, ATI Radeon HD 3690 und FireStream 9170.

-> Release Notes


Download (54mb)

[url=http://wiki.linuxgaming.de/index.php/ATI_Treiber_Installation]Installations How-To im Wiki[/url]


Neue Features:

- This release introduces Mipmap Detail, Catalyst A.I., and AA Filters in the 3D ORCA page of the Catalyst Control Center Linux Edition.


Behobene Probleme:

- Support for video playback on the second head in dual head mode is now available. Further details can be found in topic number 737-26985
- Unresolved symbols in Xorg log under RHEL 4u6 32 and 64 bit no longer occur. Further details can be found in topic number 737-34284
- The desktop background color is no longer displayed incorrectly when using xcommgr. Further details can be found in topic number 737-34285
- Change VT no longer fails when kernel module is not loaded. Further details can be found in topic number 737-34286
- Switching to the virtual terminal multiple times no longer results in X displaying corruption. Further details can be found in topic number 737-34287
- Catalyst Control Center: The Preference page is now localized for all supported languages. Further details can be found in topic number 737-34275
- The Linux kernel module is no longer installed to wrong location if the Linux kernel is updated. Further details can be found in topic number 737-34288
- Random system hangs no longer occur when calls to the ATI driver are made from Ring3. Further details can be found in topic number 737-34289
- X window no longer fails to respond when GoogleEarth is maximized. Further details can be found in topic number 737-34290
- A segmentation fault no longer occurs when running SPECViewperf on systems containing an ATI FireGL V5100 series product and running SUSE 10.3 x86. Further details can be found in topic number 737-34276
- Enabling Composite extension no longer displays 8x AA for graphic cards that do not support 8x AA under the Ubuntu 7.10 operating system. Further details can be found in topic number 737-34291
- Display corruption is no longer noticed at logon when compiz is enabled. Further details can be found in topic number 737-34292
- Launching the glxgears application no longer results in segmentation faults. Further details can be found in topic number 737-34293
- GoogleEarth: Launching the application in horizontal mode on a system running X no longer results in corruption being noticed. Further details can be found in topic number 737-34293
- Specviewperf 8.1 64 bit version: Segmentation faults no longer occurs on IGP systems. Further details can be found in topic number 737-34294
- Maya 2008: Moving the render window no longer results in the operating system failing. Further details can be found in topic number 737-34295
- Glxgears corruption is no longer noticed in big desktop mode. Further details can be found in topic number 737-34296


Bekannte Probleme:

- Desktop corruption may be noticed when dragging the overlay/video when using dual-display mode. Further details can be found in topic number 737-29578
- Bandwidth corruption may be noticed when setting the desktop resolution to 2048x1536 on systems containing an ATI Radeon HD 3200 series of product. Further details can be found in topic number 737-33499
- SECAM, NTSC or PAL signal changes when using aticonfig or Catalyst Control Center but does not apply to the TV display output. Further details can be found in topic number 737-34297
- Running X server without a window manager may result in the X server flashing green for a moment, going black, and the computer becoming unresponsive. Further details can be found in topic number 737-34299
- Desktop corruption may be noticed when dragging the overlay/video when using dual-display mode. Further details can be found in topic number 737-34298
- Connecting a CRT display device to a system containing an ATI Mobility Radeon X1600 product may result in the display device flashing multiple times or failing to display an image when attempting to launch the Catalyst Control Center. Further details can be found in topic number 737-34300
- Corruption may be noticed when connecting a DFP display device to a system running X after setting the TV mode to 1080i. Further details can be found in topic number 737-34301
- Quake 3 Arena (demo): Segmentation faults may occur when attempting to play the game. Further details can be found in topic number 737-34302
- Specviewperf: Launching the application may result in the Linux operating system failing to respond. Further details can be found in topic number 737-34282
- Opening a terminal and running semi-automated DPPT tests via lnxtest.sh may result in the operating system failing to respond. Further details can be found in topic number 737-34283
- A segmentation fault may occur when running SPECViewperf on systems containing an ATI FireGL V5100 series product and running SUSE 10.3 x86. Further details can be found in topic number 737-34319
- FGL_GLXGEARS or GLXGEARS: X may fail to respond when launching either of the applications. Further details can be found in topic number 737-34316
- Maya 2008: Various comparison failures may be noticed. Further details can be found in topic number 737-34277
- The X Server may fail to reset clearly when AIGLX is enabled. Further details can be found in topic number 737-34317
- DiscoveryStudio1.7: The print preview and save as functions may fail to work properly. Further details can be found in topic number 737-34278
- SPEC Viewperf 8.1: A performance drop may be noticed when running the application under Linux. Further details can be found in topic number 737-34279
- Maya2008: The hardware render buffer may fail to render/display the image. Further details can be found in topic number 737-34280
- May2008: The hardware render Perl script may display an error message when rendering. Further details can be found in topic number 737-34281
<3 SuL <3
Benutzeravatar
Cheeky@Boinc
 
Beiträge: 7386
Registriert: 28.06.2006, 14:19
Wohnort: Werther
Lizenz: GPL

Beitragvon Bauer87 » 21.05.2008, 23:49

AMD hat da ein nettes "Testing use only" in die untere, rechte Ecke gepackt. Ist das distributionsspezifisch oder ist denen da eine Beta rausgerutscht? (Ich benutze Debian Etch. Treiberinstallaton mache ich ohne vorherige Erstellung von Paketen.)
Raubcodierer sind Verbrecher. Stop DRM!
Benutzeravatar
Bauer87
 
Beiträge: 1233
Registriert: 31.10.2006, 23:28
Wohnort: Oldenburg
Lizenz: CC BY-SA 3.0
Distribution: Debian Stretch
Kernelversion: 4.9

Beitragvon Gast » 22.05.2008, 02:06

Na hoffentlich sind sie lauffähig auf Fedora9 ;) und Bald in den Paketquellen sonst sterb ich hier ^__^
Gast
 

Beitragvon Cheeky@Boinc » 22.05.2008, 10:43

"Testing use only"


Testing Signatur Fix:

Code: Alles auswählen
awk /^signature=/ ati-driver-installer-8-4-x86.x86_64.run

signature="e7d56ac97bfc562e683610e1a87e1b7e:dffb5efe4dd16616580522d9c9532b48d5e35af838d1177a211624d1984f2d48:83b30cab4e99304b5c5274d09e482a48d2ed5afc49ce32170b0f25d29a1c2f4683e00ffa4e9d30165b0e74d099492c1fd5e45bff49c8321f510e24879a1a2f46"

sed -i s/\(signature=\).*/\1"$signature"/ ati-driver-installer-8-5-x86.x86_64.run


Na hoffentlich sind sie lauffähig auf Fedora9


Xorg 1.5 wird weiterhin nicht unterstützt. Was daran liegt das dieser Xserver noch nicht freigegeben ist!
Ansonsten bleibt dir nur der weg über den OpenSource Treiber.
<3 SuL <3
Benutzeravatar
Cheeky@Boinc
 
Beiträge: 7386
Registriert: 28.06.2006, 14:19
Wohnort: Werther
Lizenz: GPL

Beitragvon Bauer87 » 22.05.2008, 11:57

AMD hat den Fehler offenbar bemerkt und eine verbeserte Version hoch geladen. Jetzt sieht alles so aus, wie es sein sollte und abstürze hatte ich auch noch keine - und ich bin sehr oft auf die VTerms gesprungen, habe mich abgemeldet und den Xserver neu gestartet. Alles kein Problem gewesen. Nur habe ich (wie bei den Vorversionen) sporadisch einen schwarzen Bildschirm, wenn ich Spiele starten will. Ich kann dann zwar vom VTerm aus das Spiel beenden, aber der Bug ist doch echt übel. Ich werde mal ausprobieren, wie sich das beim freien Treiber so verhält - vielleicht liegt es ja gar nicht am fglrx. Also mal fix Lenny installieren - auf Etch hab ich damit nur 2D.
Raubcodierer sind Verbrecher. Stop DRM!
Benutzeravatar
Bauer87
 
Beiträge: 1233
Registriert: 31.10.2006, 23:28
Wohnort: Oldenburg
Lizenz: CC BY-SA 3.0
Distribution: Debian Stretch
Kernelversion: 4.9


Zurück zu Hardware/Peripherie

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

cron