AMD/ATI Catalyst 8.12 (Linux 3D Treiber) erschienen

Neue Treiberversionen und Informationen zu neuer Hardware sind hier zu finden.

Moderator: Moderator

AMD/ATI Catalyst 8.12 (Linux 3D Treiber) erschienen

Beitragvon ChemicalBrother » 11.12.2008, 12:25

Bild

Catalyst 8.12 ist da!

-> Release Notes (PDF)

Download (77.6 MB)

[url=http://wiki.linuxgaming.de/index.php/ATI_Treiber_Installation]Installations How-To im Wiki[/url]


New Features

• Support for New Linux Operating Systems
• Catalyst Control Center Linux Edition: Information Center Enhacement
• ATI Stream Computing Support
• SurroundView™ support

Resolved Issues

• Primary display will remain blank after task switching between virtual terminals with dual displays running in Single Independent mode
• Executing Glxears may cause the operating system to stop responding
• Some systems may become unstable when running multiple OpenGL applications with an ATI Radeon HD 3200 Series adapter
• Catalyst Control Center fails to identify the correct display type connected
• Segmentation fault may occur when enabling bios version on systems with three or more adapters
• Executing Glxgears may cause the operating system to stop responding
• CrossFire logo is not shown when playing 3D applications in full screen mode for 64bit Linux distributions
• Desktop corruption may occur when task switching from multiple X windows keeping one console in text mode
• Alientrap NEXUIZ,a delay may occurs when exiting the game
• X11Perf benchmark no longer causes a segmentation fault durring execution
• SUSE 10.3 32bit: Unable to set modes higher than 1600x1200 from command line
• SUSE 10.3 32bit: CRT screen corruption may occur after setting horizontal and vertical sync ranges
• System with multi adapters may experience problems installing the display driver

Known Issues

• Poor performance may intermittently be noticed when running GTKPerf on systems containing an ATI Radeon HD 38x0 or newer product
• SUSE 10.3 64bit: Connecting a DFP display device as a secondary display device may occasionally result in the secondary display device failing to display an image
• Red Hat 5.2 32bit, KDM X windows may restart when user selects to "Start New Session" during user switch
• System does not switch to "Optimal Performance" when running on AC power and returning from sleep
• This version of the Catalyst Control Center - Linux Edition shows the wrong version for the Catalyst driver, the version should be 8.12


P.S.: Wäre nett, wenn jemand die Ati-Wiki-Artikel freischaltet. :-) (Und vielleicht den Artikel für Fedora aktualisiert, der ist uralt.)
Zuletzt geändert von ChemicalBrother am 29.01.2009, 23:01, insgesamt 1-mal geändert.
Benutzeravatar
ChemicalBrother
 
Beiträge: 5250
Registriert: 21.08.2006, 21:17
Wohnort: Langen
Lizenz: CC
Distribution: Arch Linux
Kernelversion: 5.9

Beitragvon tabtab » 11.12.2008, 17:47

Fedoras Artikel ist doch noch aktuell...
Man kann weiter die Livna Quellen nutzen und für Fedora 10 gibts sowieso kein funktionierenden Catalyst..
tabtab
 
Beiträge: 133
Registriert: 18.10.2008, 07:12
Lizenz: CC

Beitragvon cool j » 11.12.2008, 18:54

Stimmt nicht ganz, man kann den Treiber auch unter Fedora installieren.
Code: Alles auswählen
1) rpm -e --nodeps libdrm
2) rpm -ivh libdrm.rpm from F9
3) download and install fglrx from amd.com
4) rm /usr/lib/dri/fglrx_dri.so
5) ln -s /usr/lib64/dri/fglrx_dri.so /usr/lib/dri/fglrx_dri.so
6) yum install system-config-display
7) run system-config-display and change *nothing*, but press "ok" to create an xorg.conf.
8) aticonfig --initial -f


oder aber auch unter Verwendung der rpmfusion-Pakte (für F9) siehe [url=test]http://forums.fedoraforum.org/showpost.php?p=794199&postcount=1[/url]
Ich warte noch auf die neuen Pakete und dann teste ich mal den neuen Treiber
cool j
 
Beiträge: 113
Registriert: 17.06.2008, 17:50

Beitragvon tabtab » 11.12.2008, 22:17

[quote=cool j,index.php?page=Thread&postID=32533#post32533]Stimmt nicht ganz, man kann den Treiber auch unter Fedora installieren.
Code: Alles auswählen
1) rpm -e --nodeps libdrm
2) rpm -ivh libdrm.rpm from F9
3) download and install fglrx from amd.com
4) rm /usr/lib/dri/fglrx_dri.so
5) ln -s /usr/lib64/dri/fglrx_dri.so /usr/lib/dri/fglrx_dri.so
6) yum install system-config-display
7) run system-config-display and change *nothing*, but press "ok" to create an xorg.conf.
8) aticonfig --initial -f


oder aber auch unter Verwendung der rpmfusion-Pakte (für F9) siehe [url=test]http://forums.fedoraforum.org/showpost.php?p=794199&postcount=1[/url]
Ich warte noch auf die neuen Pakete und dann teste ich mal den neuen Treiber[/quote]

Erfolglos getestet
Fedora startet mit keinem Bild und bevor man den Treiber nicht wieder deinstalliert bekommt man auch kein x hoch (nicht mal wenn man nen anderen Treiber in die xorg.conf einträgt)
tabtab
 
Beiträge: 133
Registriert: 18.10.2008, 07:12
Lizenz: CC

Beitragvon cool j » 12.12.2008, 01:02

Sehr merkwürdig, bei mir funktionierts.
Was hast du denn für eine Graka, kann es sein, dass die gar nicht mehr vom fglrx unterstützt wird?
Wenn du die xorg.conf änderst ist das schön und gut. Es gibt da allerdings dieses init-v Skript (fglrx oder atieventds, bin mir nicht sicher welches, denke ersteres), das dafür sorgt, dass die xorg.conf wieder so angepasst wird, dass auch wirklich der fglrx geladen wird.
Dann müsstest du dieses (oder einfach beide) deaktivieren.
cool j
 
Beiträge: 113
Registriert: 17.06.2008, 17:50

Beitragvon tabtab » 12.12.2008, 01:44

[quote=cool j,index.php?page=Thread&postID=32540#post32540]Sehr merkwürdig, bei mir funktionierts.
Was hast du denn für eine Graka, kann es sein, dass die gar nicht mehr vom fglrx unterstützt wird?
Wenn du die xorg.conf änderst ist das schön und gut. Es gibt da allerdings dieses init-v Skript (fglrx oder atieventds, bin mir nicht sicher welches, denke ersteres), das dafür sorgt, dass die xorg.conf wieder so angepasst wird, dass auch wirklich der fglrx geladen wird.
Dann müsstest du dieses (oder einfach beide) deaktivieren.[/quote]

Also meine xorg.conf bleibt auf radeonHD bzw ati hab ich aus ner Liveumgebunt angeschaut bzw danach gelöscht ^^..
MEine Karte ist die RadeonX1400 Mobile welche definitiv noch unterstützt wird :p

Das es bei dir so funktioniert liegt wahrscheinlich an der 64bit Umgebung welche ich nicht habe (Zumindest steht es so in diversen Foren das es mit 64Bit geht und mit 32nicht)

Hoffentlich wird Fedora 10 vom Catalyst 9.01 unterstützt ^^ wär nett von ATI
tabtab
 
Beiträge: 133
Registriert: 18.10.2008, 07:12
Lizenz: CC

Beitragvon Cheeky@Boinc » 12.12.2008, 11:11

Ich würde bei Fedora auf die rpmfusion quellen setzen. Ansonsten bleibt nur die aktuellen Treiber testen :(
<3 SuL <3
Benutzeravatar
Cheeky@Boinc
 
Beiträge: 7387
Registriert: 28.06.2006, 14:19
Wohnort: Werther
Lizenz: GPL

Beitragvon cool j » 12.12.2008, 19:49

[quote=Tids,index.php?page=Thread&postID=32541#post32541]
Also meine xorg.conf bleibt auf radeonHD bzw ati hab ich aus ner Liveumgebunt angeschaut bzw danach gelöscht ^^..
MEine Karte ist die RadeonX1400 Mobile welche definitiv noch unterstützt wird :p

Das es bei dir so funktioniert liegt wahrscheinlich an der 64bit Umgebung welche ich nicht habe (Zumindest steht es so in diversen Foren das es mit 64Bit geht und mit 32nicht)

Hoffentlich wird Fedora 10 vom Catalyst 9.01 unterstützt ^^ wär nett von ATI[/quote]
Ja, du hast recht, ich habe 64 bit. Ich hoffe eher auf die 3D-Unterstützung des radeonhd/radeon, zu weihnachten soll es ja eventuell klappen
cool j
 
Beiträge: 113
Registriert: 17.06.2008, 17:50


Zurück zu Hardware/Peripherie

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

cron